summaryrefslogtreecommitdiff
path: root/nixos/configuration.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-11-29 07:38:10 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 08:37:49 +0100
commitb2bd12c7c0039c33b81e1e88b825e1606ee899e2 (patch)
tree086e64c980ea2da3b555f2a3cd8e2d4fcde29f6f /nixos/configuration.nix
parentdfb73342a094871a54185d90841430be087e109c (diff)
refactor: enable host-specific configuration
Diffstat (limited to 'nixos/configuration.nix')
-rw-r--r--nixos/configuration.nix74
1 files changed, 0 insertions, 74 deletions
diff --git a/nixos/configuration.nix b/nixos/configuration.nix
deleted file mode 100644
index 7d785ab..0000000
--- a/nixos/configuration.nix
+++ /dev/null
@@ -1,74 +0,0 @@
-# See the configuration.nix(5) man page and the NixOS manual (accessible by running `nixos-help`).
-
-{ config, pkgs, ... }:
-
-{
- imports = [
- ./hardware-configuration.nix
- ./sanix.nix
- ];
-
- # Bootloader.
- boot.loader.systemd-boot.enable = true;
- boot.loader.efi.canTouchEfiVariables = true;
-
- networking.hostName = "nixos"; # Define your hostname.
-
- networking.networkmanager.enable = true;
-
- time.timeZone = "Europe/Vienna";
-
- i18n.defaultLocale = "en_US.UTF-8";
-
- i18n.extraLocaleSettings = {
- LC_ADDRESS = "en_US.UTF-8";
- LC_IDENTIFICATION = "en_US.UTF-8";
- LC_MEASUREMENT = "en_US.UTF-8";
- LC_MONETARY = "en_US.UTF-8";
- LC_NAME = "en_US.UTF-8";
- LC_NUMERIC = "en_US.UTF-8";
- LC_PAPER = "en_US.UTF-8";
- LC_TELEPHONE = "en_US.UTF-8";
- LC_TIME = "en_US.UTF-8";
- };
-
- users.users.martin = {
- isNormalUser = true;
- description = "Martin";
- extraGroups = [ "networkmanager" "wheel" ];
- packages = with pkgs; [];
- };
-
- # List packages installed in system profile. To search, run:
- # $ nix search wget
- environment.systemPackages = with pkgs; [
- ];
-
- # Some programs need SUID wrappers, can be configured further or are
- # started in user sessions.
- # programs.mtr.enable = true;
- # programs.gnupg.agent = {
- # enable = true;
- # enableSSHSupport = true;
- # };
-
- # List services that you want to enable:
-
- # Enable the OpenSSH daemon.
- # services.openssh.enable = true;
-
- # Open ports in the firewall.
- # networking.firewall.allowedTCPPorts = [ ... ];
- # networking.firewall.allowedUDPPorts = [ ... ];
- # Or disable the firewall altogether.
- # networking.firewall.enable = false;
-
- # This value determines the NixOS release from which the default
- # settings for stateful data, like file locations and database versions
- # on your system were taken. It‘s perfectly fine and recommended to leave
- # this value at the release version of the first install of this system.
- # Before changing this value read the documentation for this option
- # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
- system.stateVersion = "24.05"; # Did you read the comment?
-
-}