summaryrefslogtreecommitdiff
path: root/nixos/ev-hardware-configuration.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:27:03 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 13:02:48 +0100
commitedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (patch)
tree69f22f3b10650db1e658c5ead0edd397371bf7b5 /nixos/ev-hardware-configuration.nix
parenta38027b74258a984dd959d6558440bf3078e336e (diff)
refactor: move host configs under hosts/
Diffstat (limited to 'nixos/ev-hardware-configuration.nix')
-rw-r--r--nixos/ev-hardware-configuration.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/nixos/ev-hardware-configuration.nix b/nixos/ev-hardware-configuration.nix
deleted file mode 100644
index 65300c8..0000000
--- a/nixos/ev-hardware-configuration.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-# Do not modify this file! It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations. Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
-{
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
-
- boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "usbhid" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
- boot.initrd.kernelModules = [ ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
-
- fileSystems."/" =
- { device = "/dev/disk/by-uuid/2c273b8a-7f40-41dd-ab63-2194d4bfd328";
- fsType = "ext4";
- };
-
- boot.initrd.luks.devices."luks-d9d95f9b-5f7d-4193-859f-d36dae4ed814".device = "/dev/disk/by-uuid/d9d95f9b-5f7d-4193-859f-d36dae4ed814";
-
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/83DB-4251";
- fsType = "vfat";
- options = [ "fmask=0077" "dmask=0077" ];
- };
-
- swapDevices = [ ];
-
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp0s21f0u4.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp2s0.useDHCP = lib.mkDefault true;
-
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}