summaryrefslogtreecommitdiff
path: root/nixos/hamac-configuration.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-11-29 07:38:10 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 08:37:49 +0100
commitb2bd12c7c0039c33b81e1e88b825e1606ee899e2 (patch)
tree086e64c980ea2da3b555f2a3cd8e2d4fcde29f6f /nixos/hamac-configuration.nix
parentdfb73342a094871a54185d90841430be087e109c (diff)
refactor: enable host-specific configuration
Diffstat (limited to 'nixos/hamac-configuration.nix')
-rw-r--r--nixos/hamac-configuration.nix75
1 files changed, 75 insertions, 0 deletions
diff --git a/nixos/hamac-configuration.nix b/nixos/hamac-configuration.nix
new file mode 100644
index 0000000..306260d
--- /dev/null
+++ b/nixos/hamac-configuration.nix
@@ -0,0 +1,75 @@
+# channel="nixos"
+# See the configuration.nix(5) man page and the NixOS manual (accessible by running `nixos-help`).
+
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./hamac-hardware-configuration.nix
+ ./sanix.nix
+ ];
+
+ # Bootloader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.hostName = "hamac";
+
+ networking.networkmanager.enable = true;
+
+ time.timeZone = "Europe/Vienna";
+
+ i18n.defaultLocale = "en_US.UTF-8";
+
+ i18n.extraLocaleSettings = {
+ LC_ADDRESS = "en_US.UTF-8";
+ LC_IDENTIFICATION = "en_US.UTF-8";
+ LC_MEASUREMENT = "en_US.UTF-8";
+ LC_MONETARY = "en_US.UTF-8";
+ LC_NAME = "en_US.UTF-8";
+ LC_NUMERIC = "en_US.UTF-8";
+ LC_PAPER = "en_US.UTF-8";
+ LC_TELEPHONE = "en_US.UTF-8";
+ LC_TIME = "en_US.UTF-8";
+ };
+
+ users.users.martin = {
+ isNormalUser = true;
+ description = "Martin";
+ extraGroups = [ "networkmanager" "wheel" ];
+ packages = with pkgs; [];
+ };
+
+ # List packages installed in system profile. To search, run:
+ # $ nix search wget
+ environment.systemPackages = with pkgs; [
+ ];
+
+ # Some programs need SUID wrappers, can be configured further or are
+ # started in user sessions.
+ # programs.mtr.enable = true;
+ # programs.gnupg.agent = {
+ # enable = true;
+ # enableSSHSupport = true;
+ # };
+
+ # List services that you want to enable:
+
+ # Enable the OpenSSH daemon.
+ # services.openssh.enable = true;
+
+ # Open ports in the firewall.
+ # networking.firewall.allowedTCPPorts = [ ... ];
+ # networking.firewall.allowedUDPPorts = [ ... ];
+ # Or disable the firewall altogether.
+ # networking.firewall.enable = false;
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "24.05"; # Did you read the comment?
+
+}