summaryrefslogtreecommitdiff
path: root/nixos/hosts/ev/default.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:27:03 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 13:02:48 +0100
commitedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (patch)
tree69f22f3b10650db1e658c5ead0edd397371bf7b5 /nixos/hosts/ev/default.nix
parenta38027b74258a984dd959d6558440bf3078e336e (diff)
refactor: move host configs under hosts/
Diffstat (limited to 'nixos/hosts/ev/default.nix')
-rw-r--r--nixos/hosts/ev/default.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/nixos/hosts/ev/default.nix b/nixos/hosts/ev/default.nix
new file mode 100644
index 0000000..d8b4b24
--- /dev/null
+++ b/nixos/hosts/ev/default.nix
@@ -0,0 +1,50 @@
+# channel="nixos-small"
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./hardware-configuration.nix
+ ../../sanix.nix
+ ../../parts/server.nix
+ ../../parts/tailscale.nix
+ ../../parts/basics.nix
+ ../../parts/basics-physical.nix
+ ];
+
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.hostName = "ev";
+
+ networking.networkmanager.enable = true;
+
+ time.timeZone = "Europe/Vienna";
+
+ users.users.martin = {
+ isNormalUser = true;
+ extraGroups = [
+ "networkmanager"
+ "wheel"
+ ];
+ };
+
+ # Open ports in the firewall.
+ networking.firewall.allowedTCPPorts = [
+ # Enabling openssh automatically opens its port in the firewall.
+ # For all other services we need to manually list the ports here.
+ ];
+ networking.firewall.allowedUDPPorts = [];
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "24.11"; # Did you read the comment?
+
+}