summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/default.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-03-15 07:18:02 +0100
committerMartin Fischer <martin@push-f.com>2025-03-15 07:22:37 +0100
commita407445f64d786e85fd2d00587cfa0e8a695ead5 (patch)
treea8868e4871f7fa49d91f3fb22de271ed27617838 /nixos/hosts/tente/default.nix
parent8dee00fd3a742395650c5002ecdacb357248acf5 (diff)
feat(tente): add geopos.link
Diffstat (limited to 'nixos/hosts/tente/default.nix')
-rw-r--r--nixos/hosts/tente/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/hosts/tente/default.nix b/nixos/hosts/tente/default.nix
index bcca7ad..49a1a6f 100644
--- a/nixos/hosts/tente/default.nix
+++ b/nixos/hosts/tente/default.nix
@@ -23,6 +23,7 @@ in
./matrix.nix
./monitoring.nix
"${sources.my-osm-proposals}/service.nix"
+ "${sources.my-geopos-link}/service.nix"
"${sources.my-spec-pub}/service.nix"
];
@@ -47,6 +48,20 @@ in
};
};
+ services.geopos-share =
+ let
+ domain = "geopos.link";
+ in
+ {
+ enable = true;
+ virtualHost = domain;
+ nginx = {
+ enableACME = true;
+ forceSSL = true;
+ extraConfig = helpers.mkNginxConfig domain;
+ };
+ };
+
services.spec-pub =
let
domain = "spec.pub";