summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/hardware-configuration.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:27:03 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 13:02:48 +0100
commitedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (patch)
tree69f22f3b10650db1e658c5ead0edd397371bf7b5 /nixos/hosts/tente/hardware-configuration.nix
parenta38027b74258a984dd959d6558440bf3078e336e (diff)
refactor: move host configs under hosts/
Diffstat (limited to 'nixos/hosts/tente/hardware-configuration.nix')
-rw-r--r--nixos/hosts/tente/hardware-configuration.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/hosts/tente/hardware-configuration.nix b/nixos/hosts/tente/hardware-configuration.nix
new file mode 100644
index 0000000..576ca76
--- /dev/null
+++ b/nixos/hosts/tente/hardware-configuration.nix
@@ -0,0 +1,31 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/profiles/qemu-guest.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/47b134dc-3b9a-4892-8fd5-eadef3d9e7b0";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}