summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/headscale.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 13:16:07 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 18:44:56 +0100
commit28424ccb86f9fe02c9e9f95958cf10d3a9fe3777 (patch)
tree676f8a3dae5266c24569c7c633d1247a7125c095 /nixos/hosts/tente/headscale.nix
parent1b65ba7a838e422c9bf16ddcaf796a996fa51b6b (diff)
refactor: split up tente/default.nix
Diffstat (limited to 'nixos/hosts/tente/headscale.nix')
-rw-r--r--nixos/hosts/tente/headscale.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nixos/hosts/tente/headscale.nix b/nixos/hosts/tente/headscale.nix
new file mode 100644
index 0000000..6faea12
--- /dev/null
+++ b/nixos/hosts/tente/headscale.nix
@@ -0,0 +1,35 @@
+{ config, lib, pkgs, ... }:
+
+let
+ cfg = config.headscale;
+in
+{
+ options.headscale = {
+ domain = lib.mkOption {
+ type = lib.types.str;
+ };
+ };
+
+ config = {
+ services = {
+ headscale = {
+ enable = true;
+ port = 8080;
+ # TODO: make dataDir configurable and set it to /srv/
+ settings = {
+ server_url = "https://${cfg.domain}";
+ dns = { base_domain = "tailnet"; };
+ };
+ };
+
+ nginx.virtualHosts.${cfg.domain} = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/" = {
+ proxyPass = "http://localhost:${toString config.services.headscale.port}";
+ proxyWebsockets = true;
+ };
+ };
+ };
+ };
+}