summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/monitoring.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-04-06 17:21:12 +0200
committerMartin Fischer <martin@push-f.com>2025-04-06 21:55:03 +0200
commitb4a000f541e704afb0689d43a2650b98913e1e5e (patch)
treeabb92469d757d72e8c2432e829eb2359216247ef /nixos/hosts/tente/monitoring.nix
parent51b82013660827ab96f2fabd6a623c988676f642 (diff)
tweak(tente): normalize level in Alloy to lowercase
Diffstat (limited to 'nixos/hosts/tente/monitoring.nix')
-rw-r--r--nixos/hosts/tente/monitoring.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/nixos/hosts/tente/monitoring.nix b/nixos/hosts/tente/monitoring.nix
index 7e92eed..668e1ef 100644
--- a/nixos/hosts/tente/monitoring.nix
+++ b/nixos/hosts/tente/monitoring.nix
@@ -189,6 +189,11 @@ in
source = "time"
format = "RFC3339"
}
+ stage.template {
+ // The slog package of the Go standard library prints levels as uppercase.
+ source = "level"
+ template = "{{ ToLower .Value }}"
+ }
stage.structured_metadata {
values = { level = "" }
}