summaryrefslogtreecommitdiff
path: root/nixos/parts/basics.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:45:34 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 18:44:37 +0100
commit1b65ba7a838e422c9bf16ddcaf796a996fa51b6b (patch)
treed8ec8d965f955a7f9a5c2b5c98e8a430fb0e8b6f /nixos/parts/basics.nix
parentedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (diff)
refactor: introduce profiles
Diffstat (limited to 'nixos/parts/basics.nix')
-rw-r--r--nixos/parts/basics.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/nixos/parts/basics.nix b/nixos/parts/basics.nix
deleted file mode 100644
index aa6eff9..0000000
--- a/nixos/parts/basics.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- environment.systemPackages = with pkgs; [
- git
- vim
-
- file
- htop
- ripgrep
- tree
- # TODO: use a tree alternative that understands .gitignore
- wget
- ];
-
- users.defaultUserShell = pkgs.zsh;
- programs.zsh = {
- enable = true;
-
- # Disabling compinit in /etc/zshrc so that we can call
- # compinit with a custom zcompdump location in .zshrc.
- enableGlobalCompInit = false;
- };
-
- environment.sessionVariables =
- let
- config = "$HOME/config/user";
- in
- {
- # Set environment variables for software that doesn't
- # follow the XDG Base Directory specification.
-
- ZDOTDIR = "${config}/zsh";
- };
-}