summaryrefslogtreecommitdiff
path: root/nixos/parts/basics.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-11-29 08:54:33 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 08:37:52 +0100
commitb3e73f8b5d94405e2f0fce52e8d219e37e54791d (patch)
tree7d1afa60772c8588a421bf9cd28a159d239222fe /nixos/parts/basics.nix
parent563c3eaa9c00cc8acc9835e3ec456793fe49e0ec (diff)
add zsh
Diffstat (limited to 'nixos/parts/basics.nix')
-rw-r--r--nixos/parts/basics.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nixos/parts/basics.nix b/nixos/parts/basics.nix
index 197e22e..77bc68d 100644
--- a/nixos/parts/basics.nix
+++ b/nixos/parts/basics.nix
@@ -4,4 +4,24 @@
environment.systemPackages = with pkgs; [
git
];
+
+ users.defaultUserShell = pkgs.zsh;
+ programs.zsh = {
+ enable = true;
+
+ # Disabling compinit in /etc/zshrc so that we can call
+ # compinit with a custom zcompdump location in .zshrc.
+ enableGlobalCompInit = false;
+ };
+
+ environment.sessionVariables =
+ let
+ config = "$HOME/config/user";
+ in
+ {
+ # Set environment variables for software that doesn't
+ # follow the XDG Base Directory specification.
+
+ ZDOTDIR = "${config}/zsh";
+ };
}