summaryrefslogtreecommitdiff
path: root/nixos/parts/dev.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:45:34 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 18:44:37 +0100
commit1b65ba7a838e422c9bf16ddcaf796a996fa51b6b (patch)
treed8ec8d965f955a7f9a5c2b5c98e8a430fb0e8b6f /nixos/parts/dev.nix
parentedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (diff)
refactor: introduce profiles
Diffstat (limited to 'nixos/parts/dev.nix')
-rw-r--r--nixos/parts/dev.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/nixos/parts/dev.nix b/nixos/parts/dev.nix
deleted file mode 100644
index 0d258b4..0000000
--- a/nixos/parts/dev.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- environment.sessionVariables = {
- # Tell .zshrc to source zshrc-dev.sh.
- MYNIX_DEV = "true";
- };
-
- environment.systemPackages = with pkgs; [
- rustup
- python313
- nodejs_22
-
- # CLI tools
- docker-compose
- gnumake
- jq
- just
- sqlite-interactive
- tokei
-
- (writeShellScriptBin "deploy-dir" (builtins.readFile ./scripts/deploy-dir))
-
- gcc # rustc fails if cc linker isn't found
- chromium
-
- vscodium
- # I'm installing extensions via my install-imperative script.
- ];
-
- virtualisation.podman = {
- enable = true;
- dockerSocket.enable = true;
- };
-}
-