summaryrefslogtreecommitdiff
path: root/nixos/parts/dev.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-02 20:25:06 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 08:37:52 +0100
commit9d1363f2fa33bf590148ece64457272502a310dc (patch)
tree701d39bc812904731f2594905ea585b78ffd4f35 /nixos/parts/dev.nix
parentf5af22a8d108c9008b1a2b6c99e65ff910518288 (diff)
add developer tools
Diffstat (limited to 'nixos/parts/dev.nix')
-rw-r--r--nixos/parts/dev.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/nixos/parts/dev.nix b/nixos/parts/dev.nix
new file mode 100644
index 0000000..e2ac1f6
--- /dev/null
+++ b/nixos/parts/dev.nix
@@ -0,0 +1,29 @@
+{ config, pkgs, ... }:
+
+{
+ environment.systemPackages = with pkgs; [
+ rustup
+ python313
+ nodejs_22
+
+ # CLI tools
+ docker-compose
+ gnumake
+ jq
+ just
+ sqlite-interactive
+ tokei
+
+ gcc # rustc fails if cc linker isn't found
+ chromium
+
+ vscodium
+ # I'm installing extensions via my install-imperative script.
+ ];
+
+ virtualisation.podman = {
+ enable = true;
+ dockerSocket.enable = true;
+ };
+}
+