summaryrefslogtreecommitdiff
path: root/nixos/parts/graphical.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-01 10:31:03 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 08:37:52 +0100
commit09dc1fefcf73dd3e57939105c22d050a65222211 (patch)
tree47489f7b7846e4f2c71ebf7bd565ddf5ba62dcb7 /nixos/parts/graphical.nix
parentb2bd12c7c0039c33b81e1e88b825e1606ee899e2 (diff)
add sway
The config is the default config copied from /etc/sway/config.
Diffstat (limited to 'nixos/parts/graphical.nix')
-rw-r--r--nixos/parts/graphical.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nixos/parts/graphical.nix b/nixos/parts/graphical.nix
new file mode 100644
index 0000000..93082a9
--- /dev/null
+++ b/nixos/parts/graphical.nix
@@ -0,0 +1,12 @@
+{ config, pkgs, ... }:
+
+{
+ programs.sway = {
+ enable = true;
+ # Execute sway with required environment variables for GTK apps.
+ wrapperFeatures.gtk = true;
+ };
+
+ environment.systemPackages = with pkgs; [
+ ];
+}