summaryrefslogtreecommitdiff
path: root/nixos/parts/graphical.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-21 12:08:37 +0100
committerMartin Fischer <martin@push-f.com>2024-12-21 12:08:37 +0100
commit71af66964c89c615fc86a5a7b53e3eb82b1dd6ad (patch)
tree6c59c6e19ff0e358ce73eea08e33f7545ded7484 /nixos/parts/graphical.nix
parenta65e4878a2556ac84d19781ae5bfc73397e77561 (diff)
graphical: autostart sway
Diffstat (limited to 'nixos/parts/graphical.nix')
-rw-r--r--nixos/parts/graphical.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/parts/graphical.nix b/nixos/parts/graphical.nix
index 93a3cc7..c290cc5 100644
--- a/nixos/parts/graphical.nix
+++ b/nixos/parts/graphical.nix
@@ -8,6 +8,10 @@
};
programs.ssh.startAgent = true;
+ environment.loginShellInit = ''
+ [[ "$(tty)" == /dev/tty1 ]] && exec sway
+ '';
+
environment.sessionVariables = {
# Tell .zshrc to source zshrc-graphical.sh.
MYNIX_GRAPHICAL = "true";