summaryrefslogtreecommitdiff
path: root/nixos/profiles/workstation/default.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:45:34 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 18:44:37 +0100
commit1b65ba7a838e422c9bf16ddcaf796a996fa51b6b (patch)
treed8ec8d965f955a7f9a5c2b5c98e8a430fb0e8b6f /nixos/profiles/workstation/default.nix
parentedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (diff)
refactor: introduce profiles
Diffstat (limited to 'nixos/profiles/workstation/default.nix')
-rw-r--r--nixos/profiles/workstation/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nixos/profiles/workstation/default.nix b/nixos/profiles/workstation/default.nix
new file mode 100644
index 0000000..ddc9a8c
--- /dev/null
+++ b/nixos/profiles/workstation/default.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../common
+ <top/shared/basics-physical.nix>
+ ./graphical.nix
+ ./dev.nix
+ ./create.nix
+ ];
+
+ environment.systemPackages = with pkgs; [
+ npins
+ ];
+
+ environment.sessionVariables = {
+ # Tell .zshrc to source zshrc-workstation.sh.
+ MYNIX_PROFILE = "workstation";
+ };
+}