summaryrefslogtreecommitdiff
path: root/nixos/profiles/workstation/dev.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:45:34 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 18:44:37 +0100
commit1b65ba7a838e422c9bf16ddcaf796a996fa51b6b (patch)
treed8ec8d965f955a7f9a5c2b5c98e8a430fb0e8b6f /nixos/profiles/workstation/dev.nix
parentedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (diff)
refactor: introduce profiles
Diffstat (limited to 'nixos/profiles/workstation/dev.nix')
-rw-r--r--nixos/profiles/workstation/dev.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/profiles/workstation/dev.nix b/nixos/profiles/workstation/dev.nix
new file mode 100644
index 0000000..1e04b4c
--- /dev/null
+++ b/nixos/profiles/workstation/dev.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, ... }:
+
+{
+ environment.systemPackages = with pkgs; [
+ rustup
+ python313
+ nodejs_22
+
+ # CLI tools
+ docker-compose
+ gnumake
+ jq
+ just
+ sqlite-interactive
+ tokei
+
+ (writeShellScriptBin "deploy-dir" (builtins.readFile ./scripts/deploy-dir))
+
+ gcc # rustc fails if cc linker isn't found
+ chromium
+
+ vscodium
+ # I'm installing extensions via my install-imperative script.
+ ];
+
+ virtualisation.podman = {
+ enable = true;
+ dockerSocket.enable = true;
+ };
+}
+