summaryrefslogtreecommitdiff
path: root/nixos/profiles/workstation/graphical.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-02-27 21:20:58 +0100
committerMartin Fischer <martin@push-f.com>2025-02-27 21:23:27 +0100
commit42374d30a16ca98d38ca3d73bdbd8abaaf662b3b (patch)
tree659f0935b5d77f40c9e6b9e3e47edaddb5031bcb /nixos/profiles/workstation/graphical.nix
parentf52ef901cb6459a5fe7446fe6e69eab82cb373eb (diff)
feat(workstation): generate wallpaper from roadmap.md
Diffstat (limited to 'nixos/profiles/workstation/graphical.nix')
-rw-r--r--nixos/profiles/workstation/graphical.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/profiles/workstation/graphical.nix b/nixos/profiles/workstation/graphical.nix
index 1f36658..dc05f05 100644
--- a/nixos/profiles/workstation/graphical.nix
+++ b/nixos/profiles/workstation/graphical.nix
@@ -21,12 +21,15 @@
wl-clipboard # for wl-copy and wl-paste
grim
libnotify # for notify-send
+ imagemagick # dependency of set-wallpaper
# When I ssh into a server my terminal changes to a host-specific background color via
# a LocalCommand configured in ~/.ssh/config and a ZSH function to reset the color on exit.
(writeShellScriptBin "set-bg" (builtins.readFile ./scripts/set-bg))
(writeShellScriptBin "reset-bg" (builtins.readFile ./scripts/reset-bg))
+ (writeShellScriptBin "set-wallpaper" (builtins.readFile ./scripts/set-wallpaper))
+
# graphical tools
imv
mpv