summaryrefslogtreecommitdiff
path: root/nixos/root.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-11-29 07:10:07 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 08:32:27 +0100
commit112c101c7308ddd710d0936ad8d1c010ae0dfb28 (patch)
tree5d50d6f9ba2274b154b2be8253f16b4dddfcf63e /nixos/root.nix
parent10ef42ae9d4a60dea161bae495ec1f09c8388617 (diff)
refactor: make configuration.nix main entry point
Diffstat (limited to 'nixos/root.nix')
-rw-r--r--nixos/root.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/nixos/root.nix b/nixos/root.nix
deleted file mode 100644
index b23e091..0000000
--- a/nixos/root.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ lib, pkgs, config, ... }: {
- imports = [
- # Import your main configuration
- ./configuration.nix
- ];
-
- environment.systemPackages = with pkgs; [
- # We're using niv to manage the systems Nixpkgs version, install it globally for ease
- niv
- ];
-
- # Use the Nixpkgs config and overlays from the local files for this NixOS build
- nixpkgs = {
- config = import ./nixpkgs/config.nix;
- overlays = import ./nixpkgs/overlays.nix;
- };
-
- # Makes commands default to the same Nixpkgs, config, overlays and NixOS configuration
- nix.nixPath = [
- "nixpkgs=${pkgs.path}"
- "nixos-config=${toString ./root.nix}"
- "nixpkgs-overlays=${toString ./nixpkgs/overlays.nix}"
- ];
- environment.variables.NIXPKGS_CONFIG = lib.mkForce (toString ./nixpkgs/config.nix);
-
- # Remove the stateful nix-channel command
- environment.extraSetup = ''
- rm --force $out/bin/nix-channel
- '';
-
- # This option is broken when set false, prevent people from setting it to false
- # And we implement the important bit above ourselves
- nix.channel.enable = true;
-}