summaryrefslogtreecommitdiff
path: root/nixos/sanix.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-27 08:45:34 +0100
committerMartin Fischer <martin@push-f.com>2024-12-27 18:44:37 +0100
commit1b65ba7a838e422c9bf16ddcaf796a996fa51b6b (patch)
treed8ec8d965f955a7f9a5c2b5c98e8a430fb0e8b6f /nixos/sanix.nix
parentedda7ef46bf2ae7fde9511005b4e7d40648c7e24 (diff)
refactor: introduce profiles
Diffstat (limited to 'nixos/sanix.nix')
-rw-r--r--nixos/sanix.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/nixos/sanix.nix b/nixos/sanix.nix
deleted file mode 100644
index 02d9ed5..0000000
--- a/nixos/sanix.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ lib, pkgs, config, ... }: {
- environment.systemPackages = with pkgs; [
- # We're using npins to manage the systems Nixpkgs version, install it globally for ease
- npins
- ];
-
- # Use the Nixpkgs config and overlays from the local files for this NixOS build
- nixpkgs = {
- config = import ./nixpkgs/config.nix;
- overlays = import ./nixpkgs/overlays.nix;
- };
-
- # Makes commands default to the same Nixpkgs, config, overlays and NixOS configuration
- nix.nixPath = [
- "nixpkgs=${pkgs.path}"
- "nixos-config=${toString <nixos-config>}"
- "nixpkgs-overlays=${toString ./nixpkgs/overlays.nix}"
- ];
- environment.variables.NIXPKGS_CONFIG = lib.mkForce (toString ./nixpkgs/config.nix);
-
- # Remove the stateful nix-channel command
- environment.extraSetup = ''
- rm --force $out/bin/nix-channel
- '';
-
- # This option is broken when set false, prevent people from setting it to false
- # And we implement the important bit above ourselves
- nix.channel.enable = true;
-}