summaryrefslogtreecommitdiff
path: root/nixos/sanix.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-11-29 08:01:14 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 08:32:27 +0100
commitdfb73342a094871a54185d90841430be087e109c (patch)
treec554387e9b3bb870efede3c01835f00f9c4af3d7 /nixos/sanix.nix
parent112c101c7308ddd710d0936ad8d1c010ae0dfb28 (diff)
refactor: switch to npins
niv is written in Haskell, while npins is written in Rust. I'm more comfortable with Rust. npins also seems more actively maintained. The files in npins/ were generated with: nix-shell -p npins npins init --bare npins add --name nixos channel nixos-24.05
Diffstat (limited to 'nixos/sanix.nix')
-rw-r--r--nixos/sanix.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/sanix.nix b/nixos/sanix.nix
index 4895127..02d9ed5 100644
--- a/nixos/sanix.nix
+++ b/nixos/sanix.nix
@@ -1,7 +1,7 @@
{ lib, pkgs, config, ... }: {
environment.systemPackages = with pkgs; [
- # We're using niv to manage the systems Nixpkgs version, install it globally for ease
- niv
+ # We're using npins to manage the systems Nixpkgs version, install it globally for ease
+ npins
];
# Use the Nixpkgs config and overlays from the local files for this NixOS build