summaryrefslogtreecommitdiff
path: root/nixos/tente-configuration.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-18 08:58:08 +0100
committerMartin Fischer <martin@push-f.com>2024-12-18 09:26:11 +0100
commitd2a7379876196b64fe345f47db2ab91d5315857d (patch)
treee262c7e3ca3db7944a304d51320fa6540290f8af /nixos/tente-configuration.nix
parente7990ebbba8c9b903687c177588b45e9294f8d11 (diff)
refactor: introduce domains.nix
Diffstat (limited to 'nixos/tente-configuration.nix')
-rw-r--r--nixos/tente-configuration.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/nixos/tente-configuration.nix b/nixos/tente-configuration.nix
index 3c52332..459fe87 100644
--- a/nixos/tente-configuration.nix
+++ b/nixos/tente-configuration.nix
@@ -4,7 +4,7 @@
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
let
- domain = "beta.push-f.com";
+ domains = import ./domains.nix;
acmeEmail = "martin@push-f.com";
in
{ config, lib, pkgs, ... }:
@@ -101,11 +101,10 @@ in
group = "www-data";
};
- # My personal website
- nginx.virtualHosts.${domain} = {
+ nginx.virtualHosts.${domains.personalWebsite} = {
enableACME = true;
forceSSL = true;
- root = "/srv/www/${domain}";
+ root = "/srv/www/${domains.personalWebsite}";
};
};