summaryrefslogtreecommitdiff
path: root/nixos/tente-hardware-configuration.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2024-12-11 22:41:09 +0100
committerMartin Fischer <martin@push-f.com>2024-12-11 22:41:09 +0100
commitb1d0bb8674083dac66433c291e0fb24d815252f3 (patch)
tree299aae0deced5dfa702c9131426f4c00d3d1ef19 /nixos/tente-hardware-configuration.nix
parent201a5ff63c44213e72771a5fae52741d750337fb (diff)
add VPS config
Diffstat (limited to 'nixos/tente-hardware-configuration.nix')
-rw-r--r--nixos/tente-hardware-configuration.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/tente-hardware-configuration.nix b/nixos/tente-hardware-configuration.nix
new file mode 100644
index 0000000..576ca76
--- /dev/null
+++ b/nixos/tente-hardware-configuration.nix
@@ -0,0 +1,31 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/profiles/qemu-guest.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/47b134dc-3b9a-4892-8fd5-eadef3d9e7b0";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}