summaryrefslogtreecommitdiff
path: root/nixos/hosts/hamac/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/hosts/hamac/default.nix')
-rw-r--r--nixos/hosts/hamac/default.nix86
1 files changed, 86 insertions, 0 deletions
diff --git a/nixos/hosts/hamac/default.nix b/nixos/hosts/hamac/default.nix
new file mode 100644
index 0000000..c8f40e1
--- /dev/null
+++ b/nixos/hosts/hamac/default.nix
@@ -0,0 +1,86 @@
+# channel="nixos"
+# See the configuration.nix(5) man page and the NixOS manual (accessible by running `nixos-help`).
+
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./hardware-configuration.nix
+ ../../sanix.nix
+ ../../parts/basics.nix
+ ../../parts/basics-physical.nix
+ ../../parts/graphical.nix
+ ../../parts/tailscale.nix
+ ../../parts/dev.nix
+ ../../parts/create.nix
+ ];
+
+ # Bootloader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.hostName = "hamac";
+
+ networking.networkmanager.enable = true;
+
+ time.timeZone = "Europe/Vienna";
+
+ i18n.defaultLocale = "en_US.UTF-8";
+
+ i18n.extraLocaleSettings = {
+ LC_ADDRESS = "en_US.UTF-8";
+ LC_IDENTIFICATION = "en_US.UTF-8";
+ LC_MEASUREMENT = "en_US.UTF-8";
+ LC_MONETARY = "en_US.UTF-8";
+ LC_NAME = "en_US.UTF-8";
+ LC_NUMERIC = "en_US.UTF-8";
+ LC_PAPER = "en_US.UTF-8";
+ LC_TELEPHONE = "en_US.UTF-8";
+ LC_TIME = "en_US.UTF-8";
+ };
+
+ users.users.martin = {
+ isNormalUser = true;
+ description = "Martin";
+ extraGroups = [ "networkmanager" "wheel" ];
+ packages = with pkgs; [];
+ };
+
+ services.getty = {
+ autologinUser = "martin";
+ autologinOnce = true; # only in the first tty once per boot
+ };
+
+ # List packages installed in system profile. To search, run:
+ # $ nix search wget
+ environment.systemPackages = with pkgs; [
+ ];
+
+ # Some programs need SUID wrappers, can be configured further or are
+ # started in user sessions.
+ # programs.mtr.enable = true;
+ # programs.gnupg.agent = {
+ # enable = true;
+ # enableSSHSupport = true;
+ # };
+
+ # List services that you want to enable:
+
+ # Enable the OpenSSH daemon.
+ # services.openssh.enable = true;
+
+ # Open ports in the firewall.
+ # networking.firewall.allowedTCPPorts = [ ... ];
+ # networking.firewall.allowedUDPPorts = [ ... ];
+ # Or disable the firewall altogether.
+ # networking.firewall.enable = false;
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "24.05"; # Did you read the comment?
+
+}