summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/web-personal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/hosts/tente/web-personal.nix')
-rw-r--r--nixos/hosts/tente/web-personal.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/nixos/hosts/tente/web-personal.nix b/nixos/hosts/tente/web-personal.nix
new file mode 100644
index 0000000..7c17063
--- /dev/null
+++ b/nixos/hosts/tente/web-personal.nix
@@ -0,0 +1,40 @@
+{ config, lib, pkgs, ... }:
+
+let
+ cfg = config.web-personal;
+in
+{
+ options.web-personal = {
+ domain = lib.mkOption {
+ type = lib.types.str;
+ };
+ matrixApiDomain = lib.mkOption {
+ type = lib.types.str;
+ };
+ };
+
+ config = {
+ services = {
+ nginx.virtualHosts.${cfg.domain} =
+ let
+ mkWellKnown = data: ''
+ default_type application/json;
+ add_header Access-Control-Allow-Origin *;
+ return 200 '${builtins.toJSON data}';
+ '';
+ in
+ {
+ enableACME = true;
+ forceSSL = true;
+ root = "/srv/www/${cfg.domain}";
+
+ locations."= /.well-known/matrix/server".extraConfig = mkWellKnown {
+ "m.server" = "${cfg.matrixApiDomain}:443";
+ };
+ locations."= /.well-known/matrix/client".extraConfig = mkWellKnown {
+ "m.homeserver" = { base_url = "https://${cfg.matrixApiDomain}"; };
+ };
+ };
+ };
+ };
+}