summaryrefslogtreecommitdiff
path: root/nixos/lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/lib.nix')
-rw-r--r--nixos/lib.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nixos/lib.nix b/nixos/lib.nix
index a2d8193..7880cc7 100644
--- a/nixos/lib.nix
+++ b/nixos/lib.nix
@@ -9,4 +9,24 @@ in
unitConfig.JoinsNamespaceOf = "netns@${ns}.service";
serviceConfig.NetworkNamespacePath = "/var/run/netns/${ns}";
};
+
+ mkPortProxy = service: ns: port: {
+ description = "Forward to ${service} in network namespace ${ns}";
+ requires = ["${service}.service"];
+ after = ["${service}.service"];
+ partOf = ["${service}.service"];
+ serviceConfig = {
+ Restart = "on-failure";
+ TimeoutStopSec = 300;
+ };
+ wantedBy = ["multi-user.target"];
+ script =
+ let
+ pkgs = nixpkgs.pkgs;
+ in
+ ''
+ ${pkgs.iproute2}/bin/ip netns exec ${ns} ${pkgs.iproute2}/bin/ip link set dev lo up
+ ${pkgs.socat}/bin/socat tcp-listen:${toString port},fork,reuseaddr exec:'${pkgs.iproute2}/bin/ip netns exec ${ns} ${pkgs.socat}/bin/socat STDIO "tcp-connect:localhost:${toString port}"',nofork
+ '';
+ };
}