summaryrefslogtreecommitdiff
path: root/nixos/parts/graphical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/parts/graphical.nix')
-rw-r--r--nixos/parts/graphical.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/nixos/parts/graphical.nix b/nixos/parts/graphical.nix
index a032ddf..990cd9e 100644
--- a/nixos/parts/graphical.nix
+++ b/nixos/parts/graphical.nix
@@ -8,6 +8,11 @@
};
programs.ssh.startAgent = true;
+ environment.sessionVariables = {
+ # Tell .zshrc to source zshrc-graphical.sh.
+ MYNIX_GRAPHICAL = "true";
+ };
+
environment.systemPackages = with pkgs; [
# CLI tools
brightnessctl