summaryrefslogtreecommitdiff
path: root/nixos/profiles/common/basics.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/profiles/common/basics.nix')
-rw-r--r--nixos/profiles/common/basics.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nixos/profiles/common/basics.nix b/nixos/profiles/common/basics.nix
new file mode 100644
index 0000000..aa6eff9
--- /dev/null
+++ b/nixos/profiles/common/basics.nix
@@ -0,0 +1,35 @@
+{ config, pkgs, ... }:
+
+{
+ environment.systemPackages = with pkgs; [
+ git
+ vim
+
+ file
+ htop
+ ripgrep
+ tree
+ # TODO: use a tree alternative that understands .gitignore
+ wget
+ ];
+
+ users.defaultUserShell = pkgs.zsh;
+ programs.zsh = {
+ enable = true;
+
+ # Disabling compinit in /etc/zshrc so that we can call
+ # compinit with a custom zcompdump location in .zshrc.
+ enableGlobalCompInit = false;
+ };
+
+ environment.sessionVariables =
+ let
+ config = "$HOME/config/user";
+ in
+ {
+ # Set environment variables for software that doesn't
+ # follow the XDG Base Directory specification.
+
+ ZDOTDIR = "${config}/zsh";
+ };
+}