summaryrefslogtreecommitdiff
path: root/nixos/profiles/workstation/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/profiles/workstation/default.nix')
-rw-r--r--nixos/profiles/workstation/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/nixos/profiles/workstation/default.nix b/nixos/profiles/workstation/default.nix
index ddc9a8c..3be5c6c 100644
--- a/nixos/profiles/workstation/default.nix
+++ b/nixos/profiles/workstation/default.nix
@@ -1,5 +1,8 @@
{ config, pkgs, ... }:
+let
+ npins = import ../../npins;
+in
{
imports = [
../common
@@ -9,12 +12,17 @@
./create.nix
];
- environment.systemPackages = with pkgs; [
- npins
+ environment.systemPackages = [
+ pkgs.npins
+ (pkgs.callPackage "${npins.agenix}/pkgs/agenix.nix" {})
];
environment.sessionVariables = {
# Tell .zshrc to source zshrc-workstation.sh.
MYNIX_PROFILE = "workstation";
};
+
+ # Age defaults to this anyway when openssh is enabled.
+ # We're setting this here for workstations where openssh is disabled.
+ age.identityPaths = ["/etc/ssh/ssh_host_ed25519_key"];
}