{ config, lib, ... }:

let
  cfg = config.gotify;
in
{
  options.gotify = {
    port = lib.mkOption {
      type = lib.types.int;
    };
  };

  config = {
    services.gotify = {
      enable = true;
      environment = {
        GOTIFY_SERVER_PORT = cfg.port;
      };
    };
  };
}