aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2022-07-30 19:50:33 +0200
committerMartin Fischer <martin@push-f.com>2022-07-30 22:21:23 +0200
commit127597a9ced661cd94f3f5a4feecef74eb197334 (patch)
tree607cbd05f00e10ac246fcb07f8da9184e7f12855 /Cargo.toml
parent56c071bb832304ba9a2ec67215b1a8ae40723840 (diff)
drop unneeded indirect openssl dependency
Since adding the rlua dependency I can no longer execute gitpad built on my developer machine on my server, since it fails with: gitpad2: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by gitpad2) As it turns out an easy workaround is to statically link MUSL (by passing --target x86_64-unknown-linux-musl to cargo build). The openssl-sys dependency (pulled in by git2) however failed to build for MUSL. Since we don't need it the simplest solution is to just drop it.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3bf7535..cb4d100 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,7 +29,7 @@ difference = { version = "2.0" }
pulldown-cmark = { version = "0.9" }
httpdate = "1"
-git2 = "0.14"
+git2 = { version = "0.14", default-features = false }
url = "2.2"