aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2021-04-08 08:42:01 +0200
committerMartin Fischer <martin@push-f.com>2021-04-08 15:40:37 +0200
commit57e7eefcbe6fb8c3dc4b01c707be9de4c34963a7 (patch)
tree6a9d296389bf3023396592c8514ed6712e011c7f /Cargo.toml
import https://github.com/servo/html5ever
commit d1206daa740305f55a5fa159e43eb33afc359cb4
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3caf8c6
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+
+name = "html5ever"
+version = "0.25.1"
+authors = [ "The html5ever Project Developers" ]
+license = "MIT / Apache-2.0"
+repository = "https://github.com/servo/html5ever"
+description = "High-performance browser-grade HTML5 parser"
+documentation = "https://docs.rs/html5ever"
+build = "build.rs"
+categories = [ "parser-implementations", "web-programming" ]
+edition = "2018"
+
+[dependencies]
+log = "0.4"
+mac = "0.1"
+markup5ever = { version = "0.10", path = "../markup5ever" }
+
+[dev-dependencies]
+typed-arena = "1.3.0"
+criterion = "0.3"
+
+[build-dependencies]
+quote = "1"
+syn = { version = "1", features = ["extra-traits", "full", "fold"] }
+proc-macro2 = "1"
+
+[[bench]]
+name = "html5ever"
+harness = false