diff options
author | Martin Fischer <martin@push-f.com> | 2023-08-11 19:37:09 +0200 |
---|---|---|
committer | Martin Fischer <martin@push-f.com> | 2023-08-19 06:39:08 +0200 |
commit | b48e5c3b99fd537d223cb899e8675177d77e650c (patch) | |
tree | d614c5c0950f75d677fb5e9e351c19a30d140257 /Cargo.toml | |
parent | 900c12ee92ee9dfff7e2c52770ba17a0c51f837f (diff) |
refactor: move html5lib test to own crate to fix `cargo test`
Previously `cargo test` failed because it ran the test_html5lib
integration test, which depends on the integration-tests feature
(so you always had to run `cargo test` with
`--features integration-tests` or `--all-features`, which was annoying).
This commit moves the integration tests to another crate,
so that the dependency on the feature can be properly defined
in a way so that `cargo test` just works and runs the test.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -1,3 +1,7 @@ +[workspace] +members = [".", "integration_tests"] +default-members = [".", "integration_tests"] + [package] name = "html5tokenizer" authors = ["Markus Unterwaditzer <markus-honeypot@unterwaditzer.net>", "Martin Fischer <martin@push-f.com>"] @@ -12,10 +16,6 @@ include = ["src/**/*", "LICENSE", "README.md"] [dev-dependencies] codespan-reporting = "0.11.1" -glob = "0.3.1" -pretty_assertions = "1.0.0" -serde = { version = "1.0.130", features = ["derive"] } -serde_json = "1.0.71" [features] # Feature used by integration tests in tests/ to get access to library internals. |