aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2023-08-11 18:42:39 +0200
committerMartin Fischer <martin@push-f.com>2023-08-19 06:38:52 +0200
commit900c12ee92ee9dfff7e2c52770ba17a0c51f837f (patch)
treede6c327f36003e561f4e0cea565f626e61f711aa /Cargo.toml
parentb00714411306ee6500e4ee34a81bd7f4a111169e (diff)
chore: drop test-generator dev-dependency
I want to move the test_html5lib integration test to a separate crate so that it can properly depend on the integration-tests feature in a way so that `cargo test` just works and runs the integration test. (Currently `cargo test` fails since test_html5lib depends on that feature.) However test_html5lib currently depends on the test-generator crate and test-generator doesn't support Cargo workspaces[1] and appears to be unmaintained. This commit therefore drops the test-generator dev-dependency. [1]: https://github.com/frehberg/test-generator/issues/6
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4bc6b2d..6918f79 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,10 +12,10 @@ include = ["src/**/*", "LICENSE", "README.md"]
[dev-dependencies]
codespan-reporting = "0.11.1"
+glob = "0.3.1"
pretty_assertions = "1.0.0"
serde = { version = "1.0.130", features = ["derive"] }
serde_json = "1.0.71"
-test-generator = "0.3.0"
[features]
# Feature used by integration tests in tests/ to get access to library internals.