aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2021-11-19 08:38:57 +0100
committerMartin Fischer <martin@push-f.com>2021-11-19 08:38:58 +0100
commit98ad8cec144900c7799772b3a53241825b416b4f (patch)
tree8a18df3e9ff4c4be5316112c0f02db72f9ef94f2 /Cargo.toml
parent7207abccd9dccb15eb37f43a8f763cac99be14d4 (diff)
feature gate named-entities (making phf optional)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c9086e8..a4257b3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,11 +10,17 @@ categories = [ "parser-implementations", "web-programming" ]
keywords = ["html", "html5", "tokenizer", "parser"]
edition = "2018"
+[features]
+default = ["named-entities"]
+
+# resolve named entities like &amp;
+named-entities = ["phf", "phf_codegen"]
+
[dependencies]
-phf = "0.9"
+phf = { version = "0.9", optional = true }
[build-dependencies]
-phf_codegen = "0.9"
+phf_codegen = { version = "0.9", optional = true }
[dev-dependencies]
typed-arena = "1.3.0"