aboutsummaryrefslogtreecommitdiff
path: root/html5lib_tests/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2023-08-15 10:09:53 +0200
committerMartin Fischer <martin@push-f.com>2023-08-19 06:41:55 +0200
commit379b2ed4b6665784c5d0ffea777e3df5ae84aa86 (patch)
tree936b6fc713243cdc073d4548047d11646c0e844b /html5lib_tests/Cargo.toml
parentd5a3bc85197e74ccd4fd2bc01ee1fe16a78ec604 (diff)
refactor: split off reusable html5lib_tests crate
Diffstat (limited to 'html5lib_tests/Cargo.toml')
-rw-r--r--html5lib_tests/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/html5lib_tests/Cargo.toml b/html5lib_tests/Cargo.toml
new file mode 100644
index 0000000..06fc6b8
--- /dev/null
+++ b/html5lib_tests/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "html5lib_tests"
+authors = ["Martin Fischer <martin@push-f.com>", "Markus Unterwaditzer <markus-honeypot@unterwaditzer.net>"]
+description = "Deserializable types for the .test files from html5lib-tests."
+version = "0.0.0"
+edition = "2021"
+publish = false # prevent accidental publishes until it's ready to be published
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+serde = { version = "1.0.130", features = ["derive"] }
+serde_json = "1.0.71"
+html5tokenizer = { path = ".." } # TODO: get rid of this dependency