diff options
author | Martin Fischer <martin@push-f.com> | 2021-04-10 19:13:43 +0200 |
---|---|---|
committer | Martin Fischer <martin@push-f.com> | 2021-04-10 19:33:43 +0200 |
commit | 0ee5da0f82ffbc233bfc8bc8d338cf605728de60 (patch) | |
tree | f5f997c5fce75b355e9063ef4c25cfa787ad45d4 /Cargo.toml | |
parent | 0296cab7787b9d993ba2d932a0b261e6a9b77108 (diff) |
drop dependency on async-trait
Also has the benefit that the futures are now Sync.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -12,7 +12,7 @@ keywords = ["web", "cookie", "hyper", "hmac"] # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html [features] -hyper_body = ["hyper", "async-trait"] +hyper_body = ["hyper"] hyper_body_json = ["serde_json", "hyper_body"] security = ["base64", "hmac", "rand", "sha2"] @@ -25,7 +25,6 @@ mime = "0.3" thiserror = "1.0" hyper = { version = "0.14", optional = true } -async-trait = { version = "0.1", optional = true } serde_json = { version = "1.0", optional = true } base64 = { version = "0.13", optional = true } |