aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2021-01-17 19:06:58 +0100
committerMartin Fischer <martin@push-f.com>2021-01-17 20:02:05 +0100
commit61efc35b0a9c62c18a7a98419bf2ddbc0a52a42d (patch)
treeff0ef6604da7b19c0bee5785e93df4844fcc9c17 /Cargo.toml
publishv0.1.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..03f39a4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "sputnik"
+version = "0.1.0"
+authors = ["Martin Fischer <martin@push-f.com>"]
+license = "MIT"
+description = "A lightweight layer on top of hyper to facilitate building web applications."
+repository = "https://git.push-f.com/sputnik"
+edition = "2018"
+categories = ["web-programming::http-server"]
+keywords = ["hyper", "web", "cookie", "csrf", "hmac"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+hyper = "0.13"
+cookie = { version = "0.14", features = ["percent-encode"] }
+serde = { version = "1.0", features = ["derive"] }
+serde_urlencoded = "0.7.0"
+base64 = "0.8"
+hmac = "0.10"
+httpdate = "0.3.2"
+mime = "0.3"
+rand = "0.7.3"
+sha2 = "0.9"
+time = "0.2" \ No newline at end of file