aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2021-01-25 14:47:47 +0100
committerMartin Fischer <martin@push-f.com>2021-01-25 15:06:48 +0100
commit9fa7442e41bc11ab3d62f43f5f6e90b59e160da2 (patch)
treec61b9dee4e03037f31d3761a17c8805ccade9cdd /Cargo.toml
parent76e92d7281b45ce506046a8946b7fde3355c485d (diff)
simplify CSRF API
This commit gets rid of the CsrfToken type, simplifying submission handling: // before let csrf_token = req.csrf_token(&mut response); let msg: FormData = body.into_form_csrf(&csrf_token).await?; // after let msg: FormData = body.into_form_csrf(req).await?; As well as HTML input retrieval: // before req.csrf_token(&mut response).html_input(); // after req.csrf_html_input(&mut response); This commit also merges the CsrfError type into CsrfProtectedFormError. bump version to 0.3.1
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 62d1f54..6925869 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "sputnik"
-version = "0.3.0"
+version = "0.3.1"
authors = ["Martin Fischer <martin@push-f.com>"]
license = "MIT"
description = "A lightweight layer on top of hyper to facilitate building web applications."