diff options
author | Martin Fischer <martin@push-f.com> | 2021-01-25 16:56:08 +0100 |
---|---|---|
committer | Martin Fischer <martin@push-f.com> | 2021-01-25 16:59:00 +0100 |
commit | e04c832200f38ab49ce8e7a6d08ffc549b8a98e2 (patch) | |
tree | e3a5e090a7794580bb2899a9c862b19761249deb /Cargo.toml | |
parent | 9fa7442e41bc11ab3d62f43f5f6e90b59e160da2 (diff) |
introduce optional SputnikBody::into_json()
bump version to 0.3.2
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 12 |
1 files changed, 10 insertions, 2 deletions
@@ -1,6 +1,6 @@ [package] name = "sputnik" -version = "0.3.1" +version = "0.3.2" authors = ["Martin Fischer <martin@push-f.com>"] license = "MIT" description = "A lightweight layer on top of hyper to facilitate building web applications." @@ -11,6 +11,9 @@ keywords = ["hyper", "web", "cookie", "csrf", "hmac"] # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html +[features] +json = ["serde_json"] + [dependencies] hyper = "0.13" cookie = { version = "0.14", features = ["percent-encode"] } @@ -24,4 +27,9 @@ rand = "0.7.3" sha2 = "0.9" time = "0.2" thiserror = "1.0" -async-trait = "0.1.42"
\ No newline at end of file +async-trait = "0.1.42" +serde_json = { version = "1.0.61", optional = true } + +[package.metadata.docs.rs] +all-features = true +rustdoc-args = ["--cfg", "docsrs"]
\ No newline at end of file |