aboutsummaryrefslogtreecommitdiff
path: root/examples/csrf/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2021-01-18 10:03:50 +0100
committerMartin Fischer <martin@push-f.com>2021-01-18 10:17:10 +0100
commit9b2d39933f3403245f97247166818bef609a0125 (patch)
treee5819cf6314e357b7b37e23ae277cd2fea165afc /examples/csrf/Cargo.toml
parentc27c5b3109e2b4fd8cdbe312f4925edc238a25e9 (diff)
split Request wrapper into Parts & Bodyv0.2.0
Originally the into_ functions actually consumed the request but I changed that to make request information like URI and method still accessible after the request has been read. Not consuming the Request however allows e.g. into_form() to be called twice, which results in a panic since the body can only be read once. This commit splits the Request wrapper into two wrappers Parts & Body, allowing the borrow checker to guarantee that the body is only consumed once, while keeping the other request information accessible after the body has been consumed. Version bumped to 0.2.0.
Diffstat (limited to 'examples/csrf/Cargo.toml')
-rw-r--r--examples/csrf/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/csrf/Cargo.toml b/examples/csrf/Cargo.toml
new file mode 100644
index 0000000..1f0066b
--- /dev/null
+++ b/examples/csrf/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "csrf"
+version = "0.1.0"
+authors = ["Martin Fischer <martin@push-f.com>"]
+edition = "2018"
+publish = false
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+hyper = "0.13"
+sputnik = {path = "../../"}
+serde = { version = "1.0", features = ["derive"] }
+tokio = { version = "0.2", features = ["full"] } \ No newline at end of file