diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 12 |
1 files changed, 10 insertions, 2 deletions
@@ -1,6 +1,6 @@ [package] name = "sputnik" -version = "0.3.1" +version = "0.3.2" authors = ["Martin Fischer <martin@push-f.com>"] license = "MIT" description = "A lightweight layer on top of hyper to facilitate building web applications." @@ -11,6 +11,9 @@ keywords = ["hyper", "web", "cookie", "csrf", "hmac"] # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html +[features] +json = ["serde_json"] + [dependencies] hyper = "0.13" cookie = { version = "0.14", features = ["percent-encode"] } @@ -24,4 +27,9 @@ rand = "0.7.3" sha2 = "0.9" time = "0.2" thiserror = "1.0" -async-trait = "0.1.42"
\ No newline at end of file +async-trait = "0.1.42" +serde_json = { version = "1.0.61", optional = true } + +[package.metadata.docs.rs] +all-features = true +rustdoc-args = ["--cfg", "docsrs"]
\ No newline at end of file |