aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 0 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b02d011..7abd2a5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,7 +14,6 @@ keywords = ["web", "cookie", "hyper", "hmac"]
[features]
hyper_body = ["hyper"]
hyper_body_json = ["serde_json", "hyper_body"]
-security = ["base64", "hmac", "rand", "sha2"]
[dependencies]
http = "0.2"
@@ -27,11 +26,6 @@ thiserror = "1.0"
hyper = { version = "0.14", optional = true }
serde_json = { version = "1.0", optional = true }
-base64 = { version = "0.13", optional = true }
-hmac = { version = "0.12", optional = true }
-rand = { version = "0.8", optional = true }
-sha2 = { version = "0.10", optional = true }
-
[package.metadata.docs.rs]
all-features = true
rustdoc-args = ["--cfg", "docsrs"]