diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 10 |
1 files changed, 6 insertions, 4 deletions
@@ -14,18 +14,15 @@ keywords = ["web", "cookie", "hyper", "hmac"] [features] hyper_body = ["hyper", "async-trait"] hyper_body_json = ["serde_json", "hyper_body"] +security = ["base64", "hmac", "rand", "sha2"] [dependencies] http = "0.2" cookie = { version = "0.15", features = ["percent-encode"] } serde = { version = "1.0", features = ["derive"] } serde_urlencoded = "0.7.0" -base64 = "0.13" -hmac = "0.10" httpdate = "0.3.2" mime = "0.3" -rand = "0.8" -sha2 = "0.9" time = "0.2" thiserror = "1.0" @@ -33,6 +30,11 @@ hyper = { version = "0.14", optional = true } async-trait = { version = "0.1", optional = true } serde_json = { version = "1.0", optional = true } +base64 = { version = "0.13", optional = true } +hmac = { version = "0.10", optional = true } +rand = { version = "0.8", optional = true } +sha2 = { version = "0.9", optional = true } + [package.metadata.docs.rs] all-features = true rustdoc-args = ["--cfg", "docsrs"]
\ No newline at end of file |