aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Walters <rwalters@digitalstirling.com>2018-07-01 16:08:20 -0700
committerRichard Walters <rwalters@digitalstirling.com>2018-07-01 16:08:20 -0700
commitcdc3f449812d0d45a3ea271636d669eb05ba3751 (patch)
tree1f46bea16d444b84a84843aed8bc9a0ebcadced5 /CMakeLists.txt
parent0a991ade05f2e98b412301cb47cb6112a374ee8c (diff)
Refactoring
* Extract IsCharacterInSet to its own module. * Extract PercentEncodedCharacterDecoder to its own module.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bfd19d7..ab5ca79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,9 +7,13 @@ set(This Uri)
set(Headers
include/Uri/Uri.hpp
+ src/IsCharacterInSet.hpp
+ src/PercentEncodedCharacterDecoder.hpp
)
set(Sources
+ src/IsCharacterInSet.cpp
+ src/PercentEncodedCharacterDecoder.cpp
src/Uri.cpp
)