aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRichard Walters <rwalters@digitalstirling.com>2020-10-14 22:38:44 -0700
committerRichard Walters <rwalters@digitalstirling.com>2020-10-14 22:38:44 -0700
commit472c84a39a29bb9a2778cac67f5a9be78eca93bc (patch)
tree07526bd1be9922d39d36829dfaeacd9d645d2563 /Cargo.toml
parentb4fb0021700594eafe1adc8055baf40a8ab5174e (diff)
Preparation for publishing on crates.io
* Rename crate to "rhymuri" since "uri" is taken; FeelsBadMan * Bump crate version to 1.0.0. * Add categories, keywords, and repository metadata. * Update README with links to crates.io and documentation. * Add license reference in README.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6bd6d6e..53716cf 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,13 +1,14 @@
[package]
-name = "uri"
-version = "0.1.0"
+name = "rhymuri"
+version = "1.0.0"
description = "Implementation of IETF RFC 3986, Uniform Resource Identifier (URI)"
authors = ["Richard Walters <rwalters@digitalstirling.com>"]
edition = "2018"
license-file = "LICENSE.txt"
readme = "README.md"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+categories = ["parser-implementations", "web-programming"]
+keywords = ["uri", "parser"]
+repository = "https://github.com/rhymu8354/Uri.git"
[dependencies]
named_tuple = "0.1"