summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/default.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-03-27 08:27:56 +0100
committerMartin Fischer <martin@push-f.com>2025-03-27 19:50:24 +0100
commit5a0c9eb79b5618c4894397646788e77db90429e0 (patch)
tree11b41c1f174c8e091494733791d957b1a2fe701b /nixos/hosts/tente/default.nix
parentc5ff49ba30e7e4b472c4abe7fcf589e2e419c4fc (diff)
refactor: pass config to helpers
Diffstat (limited to 'nixos/hosts/tente/default.nix')
-rw-r--r--nixos/hosts/tente/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/hosts/tente/default.nix b/nixos/hosts/tente/default.nix
index a2bf681..b4a47f0 100644
--- a/nixos/hosts/tente/default.nix
+++ b/nixos/hosts/tente/default.nix
@@ -3,14 +3,14 @@
# your system. Help is available in the configuration.nix(5) man page, on
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
+{ config, lib, pkgs, ... }:
+
let
domain = "push-f.com";
acmeEmail = "martin@push-f.com";
sources = import ../../npins;
- helpers = import <top/helpers.nix>;
+ helpers = import <top/helpers.nix> { inherit config; };
in
-{ config, lib, pkgs, ... }:
-
{
imports = [
./hardware-configuration.nix