summaryrefslogtreecommitdiff
path: root/nixos/profiles/workstation/dev.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-04-02 17:25:46 +0200
committerMartin Fischer <martin@push-f.com>2025-04-02 17:25:46 +0200
commita5ad58aad1237b2acde06b74280858ede2f6e651 (patch)
tree96b16d139fb0beeb905b6114404651563972437b /nixos/profiles/workstation/dev.nix
parentb0e559f749f9ce3fc8a472de70ecbb5090425ffe (diff)
fix(workstation): update Zed for amdgpu bug workaround
Diffstat (limited to 'nixos/profiles/workstation/dev.nix')
-rw-r--r--nixos/profiles/workstation/dev.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/nixos/profiles/workstation/dev.nix b/nixos/profiles/workstation/dev.nix
index e550a4c..ea39b83 100644
--- a/nixos/profiles/workstation/dev.nix
+++ b/nixos/profiles/workstation/dev.nix
@@ -22,7 +22,11 @@
gcc # rustc fails if cc linker isn't found
chromium
- pkgs-unstable.zed-editor
+ # FUTURE: Check if Linux kernel of NixOS 25.05 still has this amdgpu bug.
+ (pkgs.writeShellScriptBin "zed" ''
+ export ZED_PATH_SAMPLE_COUNT=0 # workaround for https://github.com/zed-industries/zed/issues/26143
+ exec ${pkgs-unstable.zed-editor}/bin/zeditor "$@"
+ '')
vscodium
# I'm installing extensions via my install-imperative script.
platformio