summaryrefslogtreecommitdiff
path: root/nixos/ev-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/ev-configuration.nix')
-rw-r--r--nixos/ev-configuration.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/nixos/ev-configuration.nix b/nixos/ev-configuration.nix
new file mode 100644
index 0000000..11acf3f
--- /dev/null
+++ b/nixos/ev-configuration.nix
@@ -0,0 +1,50 @@
+# channel="nixos-small"
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./ev-hardware-configuration.nix
+ ./sanix.nix
+ ./parts/server.nix
+ ./parts/tailscale.nix
+ ./parts/basics.nix
+ ./parts/basics-physical.nix
+ ];
+
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.hostName = "ev";
+
+ networking.networkmanager.enable = true;
+
+ time.timeZone = "Europe/Vienna";
+
+ users.users.martin = {
+ isNormalUser = true;
+ extraGroups = [
+ "networkmanager"
+ "wheel"
+ ];
+ };
+
+ # Open ports in the firewall.
+ networking.firewall.allowedTCPPorts = [
+ # Enabling openssh automatically opens its port in the firewall.
+ # For all other services we need to manually list the ports here.
+ ];
+ networking.firewall.allowedUDPPorts = [];
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "24.11"; # Did you read the comment?
+
+}