summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/matrix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/hosts/tente/matrix.nix')
-rw-r--r--nixos/hosts/tente/matrix.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/hosts/tente/matrix.nix b/nixos/hosts/tente/matrix.nix
index ab6931e..7e802c6 100644
--- a/nixos/hosts/tente/matrix.nix
+++ b/nixos/hosts/tente/matrix.nix
@@ -2,6 +2,7 @@
let
cfg = config.matrix;
+ helpers = import <top/helpers.nix>;
in
{
options.matrix = {
@@ -46,6 +47,7 @@ in
nginx.virtualHosts.${cfg.apiDomain} = {
enableACME = true;
forceSSL = true;
+ extraConfig = helpers.mkNginxConfig cfg.apiDomain;
# TODO: add locations."/" with some message