summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/web-personal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/hosts/tente/web-personal.nix')
-rw-r--r--nixos/hosts/tente/web-personal.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/hosts/tente/web-personal.nix b/nixos/hosts/tente/web-personal.nix
index 7c17063..4e86e9b 100644
--- a/nixos/hosts/tente/web-personal.nix
+++ b/nixos/hosts/tente/web-personal.nix
@@ -2,6 +2,7 @@
let
cfg = config.web-personal;
+ helpers = import <top/helpers.nix>;
in
{
options.web-personal = {
@@ -27,6 +28,7 @@ in
enableACME = true;
forceSSL = true;
root = "/srv/www/${cfg.domain}";
+ extraConfig = helpers.mkNginxConfig cfg.domain;
locations."= /.well-known/matrix/server".extraConfig = mkWellKnown {
"m.server" = "${cfg.matrixApiDomain}:443";